手机游戏
经典单机
角色扮演
休闲益智
动作冒险
射击枪战
赛车竞速
模拟经营
解密闯关
策略战争
手机软件
时尚购物
体育运动
资讯阅读
教育学习
摄影摄像
生活服务
效率办公
聊天社交
视频盒子
其它软件
新闻资讯
游戏攻略
软件教程
游戏问答
软件资讯
软件技术
叨叨念念
网站技术
技术问答
软件教程
资源资料
原创作品
代码学习
网页设计
网络技术
合集
合集
游戏合集
软件合集
资讯合集
视频合集
首页 > 网络技术 > 网络技术

RouterOS多IP使用src-nat上网并对应内网IP地址

作者:星知苑 时间:2020-03-21 21:35:17

本教程主要介绍 RouterOS(以下简称ROS)多IP(多拨或者多宽带)使用src-nat上网,并指定内网的IP通过指定线路上网。

平时的教程都是masquerade伪装上网,所以这次星知苑出品的这个教程使用的是src-nat上网,主要是因为src-nat的效率比masquerade的高。

本教程不适合初学者,过程中很多步骤略过怎么配置,初学者请先学习ROS基本配置再过来查看本教程。

 

教程环境介绍:

1、ESXi6.5虚拟机虚拟ROS、Win7和WinXP

2、ROS多网卡,分别连接2个外网WAN1和WAN2,内网LAN连接Win7和WinXP[break]

3、ROS版本6.44.5

97-1.png

 

ROS配置:

1、ROS配置路由器地址:192.168.10.1,配置DHCP,使客户机动态获取到IP,这边客户机Win7获取到了192.168.10.254,WinXP获取到了192.168.10.253,网关都是192.168.10.1

 

2、ROS配置PPPoE拨号,不够添加默认路由的配置 ,分别添加PPPoE-OUT1和PPPoE-OUT2

97-2.png

 

3、添加PPPoE-OUT1和PPPoE-OUT2的路由,IP --> Routes,并做标记,这边我标记为out1和out2

97-3.png

 

4、IP --> Firewall --> Mangle设置规则,内网IP走指定标记的路由,如192.168.10.254走out1,192.168.10.253走out2。

97-4.png

97-5.png

 

5、IP --> Firewall --> NAT做src-nat上网。如192.168.10.254通过pppoe-out1上网,192.168.10.253通过pppoe-out2上网,并分别设置好Comment,便于脚本更新外网IP地址

97-6.png

97-7.png

更新外网IP地址脚本,需定时执行(我这里只提供单个IP更新脚本):

:local status [/interface get [/interface find  name="pppoe-out1"] running]
:if ($status=true) do={
:local oldip [/ip firewall nat get [find comment="out1"] to-addresses]
:local newip [/ip address get [/ip address find dynamic=yes interface="pppoe-out1"] address]
:set newip [:pick $newip 0 ([:len $newip] -3)]
:if ($newip!=$oldip) do={
/ip firewall nat set [/ip firewall nat find comment="out1"] to-addresses=$newip
}
}

 

6、到此可以上网了。

97-8.png

良心推荐

农场小镇游戏大全
  • 全民小镇破解版
  • 全民小镇官网最新版
  • 我的农场小镇村庄生活中文版
  • 我的农场小镇村庄生活破解版
  • 牧羊人之心下载安装
  • 像素牧场物语下载免费
在嘈杂的市区喧闹虽然是很热闹,但是有些时候你可能需要治愈的游戏来缓解你的压力,你可以在上面尽情的享受农民生活的最佳的方式,不管是什么的蔬菜种子都是可以让你直接的种,当然是少不了畜牧业的发展,要经营好农场是非常的辛苦,需要你坚持不懈的努力,小编这里整理了很多有关农场生活的游戏推荐给你下载。

相关资讯