手机游戏
经典单机
角色扮演
休闲益智
动作冒险
射击枪战
赛车竞速
模拟经营
解密闯关
策略战争
手机软件
时尚购物
体育运动
资讯阅读
教育学习
摄影摄像
生活服务
效率办公
聊天社交
视频盒子
其它软件
新闻资讯
游戏攻略
软件教程
游戏问答
软件资讯
软件技术
叨叨念念
网站技术
技术问答
软件教程
资源资料
原创作品
代码学习
网页设计
网络技术
合集
合集
游戏合集
软件合集
资讯合集
视频合集
首页 > 网络技术 > 网络技术

RouterOS原生脚本实现DNSPOD的DDNS动态解析

作者:星知苑 时间:2019-11-13 18:52:40

我前面有文章《RouterOS利用DNSPOD的API接口实现DDNS动态解析》写过通过PHP服务器更新DNSPOD解析的域名IP,但是更多的是带来安全问题,所有这次写了一个RouterOS(以下简称ROS)的原生脚本来实现域名的动态解析。

 

脚本说明:

1. 不存在的记录,不会自动添加,需要手动在DNSPOD添加记录,线路为默认,不支持单记录多线路解析。

2. 只支持IPv4,不支持IPv6

3. 脚本中需要自己修改的信息

pppoe,拨号连接的名称,如pppoe-out1[break]

token,dnspod的token。id和token之间用半角逗号连接(英文状态下的逗号)

domain,域名

subdomain,主机记录

 

版本更新:

1.0 beta  by 2019/11/13

1. 测试版本,有任何问题请留言。

2. 为什么不加自动了添加域名之类的,因为一次添加永久有效,所以脚本中不添加自动了。节省ROS性能(我懒)

 

脚本代码:

#PPPoE
:local pppoe "ADSL-PPPoE"

#DNSPOD token
:local token "xxxxx,xxxxxxxxxxxxxxxxxxx"

#域名
:local domain "myxzy.com"

#域名主机名
:local subdomain "www"

#以下不是专业人士请不要修改
#domain
:local dname ($subdomain.".".$domain)

#获取pppoe拨号ip
:local ipaddr [/ip address get [/ip address find interface=$pppoe] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]

#获取域名列表
:local record [/tool fetch url="https://dnsapi.cn/Record.List" http-data="login_token=$token&format=json&domain=$domain&sub_domain=$subdomain&record_type=A" as-value output=user]

#获取id和ip
:set record ($record->"data")
:set record [:pick $record [:find $record ""records":"] [:len $record]]
:local recordid [:pick $record ([:find $record ""id":""]+6) [:find $record "","ttl"]]
:local recordip [:pick $record ([:find $record ""value":""]+9) [:find $record "","en"]]

#更新ip地址
:if ($recordip!=$ipaddr) do={
/tool fetch url="https://dnsapi.cn/Record.Ddns" http-data="login_token=$token&format=json&domain=$domain&sub_domain=$subdomain&record_id=$recordid&record_line_id=0&value=$ipaddr"
:log info ("[".$dname."] ip update")
} else={
:log info ("[".$dname."] ip not update")
}

良心推荐

买卖房子哪个平台最好
  • 多多卖房app手机版
  • 房得宝下载
  • 居理买房网下载
  • 找房菌app
  • 焦点好房app下载
  • 巴乐兔租房app官网
随着人口的增多,房子是一直都是现在很火热的话题,在现在的手机软件当中,有着太多的不同房子买卖的平台,有时候让你眼花缭乱,不管是靠不靠谱专不专业的你都想去尝试一下,但是往往会浪费很多的时间,这里小编提供了很多的良心专业又靠谱的买卖房子的平台app,真正能够帮助你在不管是要买卖还是租房都可以服务很到位的。

相关资讯