手机游戏
经典单机
角色扮演
休闲益智
动作冒险
射击枪战
赛车竞速
模拟经营
解密闯关
策略战争
手机软件
时尚购物
体育运动
资讯阅读
教育学习
摄影摄像
生活服务
效率办公
聊天社交
视频盒子
其它软件
新闻资讯
游戏攻略
软件教程
游戏问答
软件资讯
软件技术
叨叨念念
网站技术
技术问答
软件教程
资源资料
原创作品
代码学习
网页设计
网络技术
合集
合集
游戏合集
软件合集
资讯合集
视频合集
首页 > 网络技术 > 网络技术

RouterOS使用EOIP隧道异地组网

作者:星知苑 时间:2021-02-12 08:07:25

MikroTik RouterOS(以下简称ROS)自由协议EoIP(Ethernet over IP)隧道是一个建立在两个ROS路由器的IP传输层之间的以太网隧道协议。EoIP Tunnel类似以太网传输,当路由器的桥接功能被启用后,所有的以太网数据流量(所有的以太网协议)将被桥接就如同在两个路由器之间有物理交换机接口和光纤收发器一样。

 

一、网络拓扑和环境

ROS1和ROS2网络间实现互通互联,ROS1为总出口,上网和DHCP服务器;ROS2为异地分部,通过EoIP Tunnel接入总部ROS1,实现通过ROS1分配DHCP地址,以及上网。

模拟环境介绍:

1、使用PPPoE公网IP模拟专线固定IP[break]

2、使用Ros x86 6.46.8 (long-term)

504-1.png

 

二、上网配置

ROS1和ROS2上网配置(这边就不详细介绍了,请查看我以前的文章)

 

ROS1上网配置:

/interface pppoe-client add add-default-route=yes disabled=no interface=ether2 name=pppoe-out1 password=admin user=admin
/ip firewall nat add action=masquerade chain=srcnat
/ip dns set allow-remote-requests=yes servers=8.8.8.8

 

ROS2上网配置:

/interface pppoe-client add add-default-route=yes disabled=no interface=ether2 name=pppoe-out1 password=admin user=admin

 

三、创建EoIP隧道

1、ROS1创建EoIP隧道

Interfaces --> EoIP Tunnel --> + , 添加一条EoIP Tunnel

Remote Address:填ROS2的IP地址(动态IP可以使用域名)

Tunnel ID:数字(隧道识别号,需要匹配)

504-3.png

/interface eoip add name=eoip-tunnel1 remote-address=ros2.myxzy.com tunnel-id=100

 

2、ROS2创建EoIP隧道

Interfaces --> EoIP Tunnel --> + , 添加一条EoIP Tunnel

Remote Address:填ROS1的IP地址(动态IP可以使用域名)

Tunnel ID:数字(隧道识别号,需要匹配)

504-2.png

/interface eoip add name=eoip-tunnel1 remote-address=ros1.myxzy.com tunnel-id=100

 

四、创建VLAN

1、ROS1创建VLAN100

Interfaces --> VLAN --> + , 添加一条vlan

Name:vlan100

VLAN ID:100

Interface:eiop-tunnel1

504-12.png

 

2、ROS2创建VLAN100

Interfaces --> VLAN --> + , 添加一条vlan

Name:vlan100

VLAN ID:100

Interface:eiop-tunnel1

504-11.png

 

五、创建Bridge

1、ROS1创建bridge

Bridge --> Bridge -->+,添加一个Bridge

Bridge --> Ports-->+,把Lan网口和vlan100加入到bridge中

504-4.png

504-5.png

504-6.png

/interface bridge add name=bridge1
/ip address add address=192.168.88.1/24 interface=bridge1 network=192.168.88.0
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=vlan100

 

2、ROS2创建bridge

Bridge --> Bridge -->+,添加一个Bridge(不要开启STP)

Bridge --> Ports-->+,把Lan网口和vlan100加入到bridge中

504-7.png

504-8.png

504-9.png

/interface bridge add protocol-mode=none name=bridge1
/ip address add address=192.168.88.2/24 interface=bridge1 network=192.168.88.0
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=vlan100

 

六、ROS1创建DHCP

这里也不详细说明了。

/ip pool add name=dhcp_pool0 ranges=192.168.88.2-192.168.88.253
/ip dhcp-server add address-pool=dhcp_pool0 disabled=no interface=bridge1 name=dhcp1
/ip dhcp-server network add address=192.168.88.0/24 dns-server=192.168.88.1 gateway=192.168.88.1

到了这里已经实现了异地组网。

良心推荐

经典fc游戏大全安卓版
  • 下载经典坦90克大战
  • 炸经典弹超人游戏原版下载
  • 松鼠大作战2手机版下载
  • 松鼠大战重制版
  • 激龟快打手机版
  • 赤色要塞无敌版安卓
小的时候总是会在家里叫上几个小玩伴一起坐在地上开着风扇,玩红白机超级玛丽坦克大战魂斗罗三国志等等一张卡带都是有很多的不同的游戏,轮流上场两两对战多种好玩的游戏,每次都是玩得不亦乐乎开怀大笑,本站小编专门花了大量的时间去寻找到很多的手机可以玩的FC游戏,再次唤醒你的童心。

相关资讯