手机游戏
经典单机
角色扮演
休闲益智
动作冒险
射击枪战
赛车竞速
模拟经营
解密闯关
策略战争
手机软件
时尚购物
体育运动
资讯阅读
教育学习
摄影摄像
生活服务
效率办公
聊天社交
视频盒子
其它软件
新闻资讯
游戏攻略
软件教程
游戏问答
软件资讯
软件技术
叨叨念念
网站技术
技术问答
软件教程
资源资料
原创作品
代码学习
网页设计
网络技术
合集
合集
游戏合集
软件合集
资讯合集
视频合集
首页 > 网络技术 > 网络技术

RouterOS通过IPsec隧道实现互访

作者:星知苑 时间:2019-06-06 21:05:33

IPSec 的两种工作模式:隧道(ip tunnel)模式和传输(ip transport)模式。简单的来说,隧道模式用于网关和网关之间的点对点连接;传输模式用于网关和电脑之间的点对点连接。具体的请自行百度。

本教程主要是RouterOS(以下简称ROS)通过IPsec隧道模式(IP tunnel)实现点对点互连。

 

一、网络拓扑

以下是一个使用 ROS实现IPsec点对点互连的案例。

 网络拓扑:PC1(10.0.0.100) --- (10.0.0.1)R1(121.236.80.94) --- 互联网 --- (117.62.85.3)R2(192.168.88.1)---(192.168.88.254)PC2[break]

493-1.png

 

二、R1路由器设置

1、IP tunnel设置:Winbox --> Interface,IP Tunnel选项卡,点击+

Remote Address填入R2外网ip地址,如117.62.85.3,点击OK

493-2.png

 

2、Winbox --> IP --> Firewall,NAT选项卡,点击+

Chain选择srcnat

Src. Address填入R1内网网段,如案列中R1的内网网段10.0.0.0/23

Dst. Address填入R2内网网段,如案列中R2的内网网段192.168.88.0/24

切换到Action选项卡,action选择accept,点击OK

注意:该条规则要在masquerade规则的上面

493-6.png

493-7.png

493-10.png

 

3、Winbox --> IP --> Firewall,NAT选项卡,修改上网的masquerade规则
Chain还是srcnat
Src. Address填入R1的内网网段,如案列中R1的内网网段10.0.0.0/23
切换到Action选项卡,action还是选择masquerade,点击OK
493-8.png

493-9.png

 

4、添加路由表,Winbox --> IP --> Routes,点击+

Dst. Address填入R2的内网ip网段,如192.168.88.0/24

Gateway选择刚才创建额ipip-tunnel1,点击OK

493-4.png

 

三、R2路由器设置

1、IP tunnel设置Winbox --> Interface,IP Tunnel选项卡,点击+

Remote Address填入R1外网ip地址,如121.236.80.94,点击OK

493-5.png

 

2、Winbox --> IP --> Firewall,NAT选项卡,点击+

Chain选择srcnat

Src. Address填入R2内网网段,如案列中R2的内网网段192.168.88.0/24

Dst. Address填入R1内网网段,如案列中R1的内网网段10.0.0.0/23

切换到Action选项卡,action选择accept,点击OK

注意:该条规则要在masquerade规则的上面

493-15.png

493-16.png

493-11.png

 

3、Winbox --> IP --> Firewall,NAT选项卡,修改上网的masquerade规则
Chain还是srcnat
Src. Address填入R1的内网网段,如案列中R1的内网网段192.188.88.0/24
切换到Action选项卡,action还是选择masquerade,点击OK

493-12.png

493-13.png

 

4、添加路由表,Winbox --> IP --> Routes,点击+

Dst. Address填入R1的内网ip网段,如10.0.0.0/23

Gateway选择刚才创建额ipip-tunnel1,点击OK

493-14.png

 

四、动态IP实现自动修改

1、2个ROS做DDNS动态ip自动更新,具体实现方法请看《RouterOS利用DNSPOD的API接口实现DDNS动态解析

 

2、2个ROS分别在Winbox --> IP --> Firewall,Address-list选项卡,点击+

Name,随便输入,如ipaddr

Address,填入对方的DDNS动态域名

493-19.png

 

3、定时脚本设置,Winbox --> system --> Scheduler,点击+

Name随便填

Interval脚本定时执行间隔,不建议设置太小

On Event:填入脚本

 

:global ipaddr
:local r2ip [/ip firewall address-list get [/ip firewall address-list find comment="ros.myxzy.com"] address]
:if ($r2ip != $ipaddr) do={
/interface ipip set ipip-tunnel1 remote-address=$r2ip
:set ipaddr $r2ip
:log info "IPIP UPDATE!"
}

 

493-20.png

另一个ROS也需要设置。

存在的问题,如果其中一个IP变更,由于DDNS的生效时间,可能会导致IP tunnel中断一段比较长的时间。我这边测试大概是1~2分钟左右(DDNS动态域名是TTL 10)。

 

五、Ping测试

493-17.png

493-18.png

至此,2个ROS已经通过IP Tunnel互通了,内网电脑可以互访了。

良心推荐

适合儿童孩子玩的手机益智游戏
  • 2048经典手机版
  • 2048经典下载安装
  • 快乐小鸡游戏免费下载
  • 恐龙机甲变形记下载
  • 女孩爱化妆游戏安卓版
  • 宝宝爱拼图游戏下载
目前随着社会的不断的进步,人类的基因也是异常的强大,很多的小朋友都是非常的聪明,条件好的家庭还可以让孩子在手机上玩各种益智儿童游戏,这样的游戏是很多的,不仅是可以发挥孩子的聪明才智提高智慧,还可以在游戏中得到很好的学习锻炼的各种机会和方式,小编这边也是整理的了一些比较适合四岁到十岁的一些益智的儿童游戏。

相关资讯