手机游戏
经典单机
角色扮演
休闲益智
动作冒险
射击枪战
赛车竞速
模拟经营
解密闯关
策略战争
手机软件
时尚购物
体育运动
资讯阅读
教育学习
摄影摄像
生活服务
效率办公
聊天社交
视频盒子
其它软件
新闻资讯
游戏攻略
软件教程
游戏问答
软件资讯
软件技术
叨叨念念
网站技术
技术问答
软件教程
资源资料
原创作品
代码学习
网页设计
网络技术
合集
合集
游戏合集
软件合集
资讯合集
视频合集
首页 > 网络技术 > 网络技术

RouterOS修改VRRP的MAC地址的方法

作者:星知苑 时间:2019-04-24 12:33:27

RouterOS(以下简称ROS)的vrrp的mac地址是固定的,不能修改,一般都是00:00:5E:00:01:01开始,所以对于很多运营商来说只要封掉00:00:5E:00:xx:xx段MAC就可以封掉多拨。

对于实体机ROS来说,可以通过Bridge的方法来修改vrrp mac地址,网上也一般是这种方法。

 

操作方法:

一、建一个外网的bridge。(这边演示ether3是外网网卡)

Winbox -> Bridge -> +  -> OK(默认就可以)[break]

484-1.png

Ports -> + -> Interface选择外网网口,这边是ether3,确定

484-2.png

/interface bridge add name=bridge1
/interface bridge port add bridge=bridge1 interface=ether3

 

二、设置vrrp以及pppoe拨号连接

参考我以前的文章《RouterOS通过VRRP实现单线多拨以及PCC负载均衡》中的设置,这边就不详细写了。

/interface vrrp
add interface=bridge1 name=vrrp1 vrid=1
add interface=bridge1 name=vrrp2 vrid=2
add interface=bridge1 name=vrrp3 vrid=3

/interface pppoe-client
add interface=vrrp1 name=pppoe-out1 password=xxxx user=xxxx
add interface=vrrp2 name=pppoe-out2 password=xxxx user=xxxx
add interface=vrrp3 name=pppoe-out3 password=xxxx user=xxxx

/ip address
add address=192.168.10.254/24 interface=bridge1 network=192.168.10.0
add address=192.168.10.1/24 interface=vrrp1 network=192.168.10.0
add address=192.168.10.2/24 interface=vrrp2 network=192.168.10.0
add address=192.168.10.3/24 interface=vrrp3 network=192.168.10.0

 

三、通过Bridge MAC NAT来修改vrrp的mac地址

1、首先开启Bridge的防火墙

Bridge -> Settings,勾上Use IP Firewall,点击ok

484-3.png

2、把vrrp修改为你需要的mac地址,有几条vrrp做几条(这边只做一条

vrrp1的mac地址是00:00:5E:00:01:01,我拨号需要的mac地址是C4:D9:87:44:03:63

Bridge -> NAT -> +,Chain选择 srcnat,Src. Mac Address地址填入vrrp1的mac地址00:00:5E:00:01:01,Src. Mac Mask默认即可

点击Action选项卡,Action选择src-nat,To Mac Address填入需要的mac地址C4:D9:87:44:03:63,确定

484-4.png

Bridge -> NAT -> +,Chain选择 dstnat,Dst. Mac Address地址填入需要的mac地址C4:D9:87:44:03:63,Dst. Mac Mask默认即可

点击Action选项卡,Action选择dst-nat,To Mac Address填入vrrp1的mac地址00:00:5E:00:01:01,确定

484-5.png

/interface bridge settings set use-ip-firewall=yes
/interface bridge nat
add action=dst-nat chain=dstnat dst-mac-address=C4:D9:87:44:03:63/FF:FF:FF:FF:FF:FF to-dst-mac-address=00:00:5E:00:01:01
add action=src-nat chain=srcnat src-mac-address=00:00:5E:00:01:01/FF:FF:FF:FF:FF:FF to-src-mac-address=C4:D9:87:44:03:63

 

 

四、查看MAC地址

无法在本地查看PPPoE的拨号MAC地址。我这边通过电信的智宽生活可以看到mac地址,发现已经更新成我自己设置的mac地址

484-6.png

良心推荐

双十一哪些软件打折
  • 日薇商城app
  • 懒人比价app
  • 名人站app
  • 爱你省app
  • 我的衣裳app
  • 蜂核1号app
网上购物已经是成为了一个生活中最常见的事情,现在人人都是用手机购买到自己喜欢的东西,而且有的平台会在上面有着很多的优惠券可以领取,非常实惠划算,而且在现在马上临近双十一的购物狂欢活动,这里小编也是整理一些可以在双十一真正的让你买到省钱很优惠的平台,完全是没有任何的套路,可以最省钱。

相关资讯