手机游戏
经典单机
角色扮演
休闲益智
动作冒险
射击枪战
赛车竞速
模拟经营
解密闯关
策略战争
手机软件
时尚购物
体育运动
资讯阅读
教育学习
摄影摄像
生活服务
效率办公
聊天社交
视频盒子
其它软件
新闻资讯
游戏攻略
软件教程
游戏问答
软件资讯
软件技术
叨叨念念
网站技术
技术问答
软件教程
资源资料
原创作品
代码学习
网页设计
网络技术
合集
合集
游戏合集
软件合集
资讯合集
视频合集
首页 > 网络技术 > 网络技术

RouterOS通过VRRP实现单线多拨以及PCC负载均衡

作者:星知苑 时间:2017-12-31 17:00:50

单线多拨/一线多拨需要运营商的支持,可以达到叠加速度(也要运营商支持)以及获取多个IP地址的目的。

ROS可以通过VRRP显示PPPOE多拨,本文虚拟机虚拟ROS以及自建PPPoE服务器,WAN口是ether1,LAN口是ether2,来实现1线3拨以及使用PCC规则来达到负载均衡的效果。

 

1、VRRP设置

打开“Interfaces” - “VRRP”,点击“+”[break]

459-1.png

添加3个VRRP,name分别为vrrp1,vrrp2,vrrp3

459-2.png

VRRP选项卡分别设置vrrp1的VRID为1,vrrp2的VRID为2,vrrp3的VRID为3

459-3.png

2、PPPoE Client拨号设置

打开“PPP” - “Interface”,点击“+”,选择“PPPoE Client”

459-4.png

创建3个pppoe拨号,name分别为pppoe-out1,pppoe-out2,pppoe-out3,以及Interfaces分别选择vrrp1,vrrp2,vrrp3

459-5.png

Dial out选项卡。分别去掉“Add Default Route”的勾(不添加默认路由)

459-6.png

3、配置LAN ip地址和激活vrrp虚拟接口配置ip地址

打开“IP” - “Addresses”,点击“+”

459-7.png

添加内网LAN:Addess:192.168.1.1/24 Network:192.168.1.0 Interface:ether2

添加外网WAN:Addess:192.168.88.1/24 Network:192.168.88.0 Interface:ether1

添加vrrp1:Addess:192.168.88.11/24 Network:192.168.88.0 Interface:vrrp1

添加vrrp2:Addess:192.168.88.12/24 Network:192.168.88.0 Interface:vrrp2

添加vrrp3:Addess:192.168.88.13/24 Network:192.168.88.0 Interface:vrrp3

PS:Wan口也就是ether1要和vrrp同一个网段的

459-8.png

4、路由设置

打开“IP” - “Routes”,点击“+”

459-9.png

添加3条默认路由Gateway:pppoe-out1,Gateway:pppoe-out2,Gateway:pppoe-out3,分别对标记为R1,R2,R3指定线路

459-10.png

5、标记内网要走的线路以及提取路由标记指定走pppoe线路

打开“ip” - “Firewall” - “Mangle”,点击“+”

459-11.png

添加3条标记规则

Chain选择“prerouting”,Src.Address填写内网ip(我这里是192.168.1.0/24),这边3条标记都是一样的

459-12.png

advanced选项卡,Per Connection Classifier选择“both addresses”

第一条标记:“both addresses”:3/0,

第二条标记:“both addresses”:3/1,

第三条标记:“both addresses”:3/2

459-13.png

Extra选项卡 Dst.Address Type中Address Type选择local,并勾上Invert,表示非本地,三条标记一样

459-14.png

Action选项卡 Action选择“mark connection”,New Connection Mark填写标记名称

第一条标记New Connection Mark填写PCC1

第二条标记New Connection Mark填写PCC2

第三条标记New Connection Mark填写PCC3

459-15.png

 

新建3条提取路由标记和指定路由的规则

Chain选择“prerouting”,Src. Address填写内网LAN地址,我这里是192.168.1.0/24,Connection Mark填写刚才标记的名称(需要创建3条规则)

第一条Connection Mark填写PCC1

第二条Connection Mark填写PCC2

第三条Connection Mark填写PCC3

459-16.png

这边Action选择“mark routing”,New Routing Mark填写要走pppoe的名称,这边3条规则分别填写R1,R2,R3 

459-17.png

以上规则脚本代码:

/ip firewall mangle
add action=mark-connection chain=prerouting dst-address-type=!local 
    new-connection-mark=PCC1 passthrough=yes per-connection-classifier=
    both-addresses:3/0 src-address=192.168.1.0/24
add action=mark-connection chain=prerouting dst-address-type=!local 
    new-connection-mark=PCC2 passthrough=yes per-connection-classifier=
    both-addresses:3/1 src-address=192.168.1.0/24
add action=mark-connection chain=prerouting dst-address-type=!local 
    new-connection-mark=PCC3 passthrough=yes per-connection-classifier=
    both-addresses:3/2 src-address=192.168.1.0/24
add action=mark-routing chain=prerouting connection-mark=PCC1 
    new-routing-mark=R1 passthrough=yes src-address=192.168.1.0/24
add action=mark-routing chain=prerouting connection-mark=PCC2 
    new-routing-mark=R3 passthrough=yes src-address=192.168.1.0/24
add action=mark-routing chain=prerouting connection-mark=PCC3 
    new-routing-mark=R2 passthrough=yes src-address=192.168.1.0/24

6、路由回路配置,确保同一个会话的数据从相同出口进出。

新建3条input规则,设置Chain:input,In.Interface选择入口

第一条规则:In.Interface选择pppoe-out1

第二条规则:In.Interface选择pppoe-out2

第三条规则:In.Interface选择pppoe-out3

459-18.png

标记入口连接,action选择mark connection,New Connectin Mark选择对应的标记

第一条规则:New Connectin Mark选择PCC1

第二条规则:New Connectin Mark选择PCC2

第三条规则:New Connectin Mark选择PCC3

459-19.png

 

新建3条output规则,设置Chain:output,Connectin Mark选择刚才标记的

第一条规则:Connectin Mark选择PCC1

第二条规则:Connectin Mark选择PCC2

第三条规则:Connectin Mark选择PCC3

459-20.png

标记默认路由,action选择mark routing,New Routing Mark选择对应的标记

第一条规则:New Routing Mark选择R1

第二条规则:New Routing Mark选择R2

第三条规则:New Routing Mark选择R3

459-21.png

以上规则脚本代码:

/ip firewall mangle
add action=mark-connection chain=input in-interface=pppoe-out1 
    new-connection-mark=PCC1 passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out3 
    new-connection-mark=PCC3 passthrough=yes
add action=mark-connection chain=input in-interface=pppoe-out2 
    new-connection-mark=PCC2 passthrough=yes
add action=mark-routing chain=output connection-mark=PCC1 new-routing-mark=R1 
    passthrough=yes
add action=mark-routing chain=output connection-mark=PCC3 new-routing-mark=R3 
    passthrough=yes
add action=mark-routing chain=output connection-mark=PCC2 new-routing-mark=R2 
    passthrough=yes

7、配置nat规则

打开“IP” - “Firewall” -“NAT” ,点击“+”

459-22.png

创建一条规则,Chain选择srcnat

459-23.png

action选项卡,action选择masquerade

459-24.png

以上规则脚本代码:

/ip firewall nat
add action=masquerade chain=srcnat

到此差不多结束了。实际环境存在的问题就是当有PPPoE掉线的时候,会导致内网部分网络不通。可以使用脚本来解决。

良心推荐

传奇游戏手机所有版本下载
  • 传奇无限元宝版本
  • 蓝月王者正版下载
  • 蓝月至尊版无限元宝
  • 传奇手游h5无限元宝服破解版
  • 传奇游戏内购破解版下载
  • 蓝月至尊版满v变态版
复古的游戏画面,还可以让你直接的挂机非常让一些喜欢怀旧的玩家的喜欢,想当年那种你在各种网吧或是在家里,三更半夜起来刷各种戒指或者是装备,满满都是情怀和回忆,小编自己也是玩传奇出身的,在现在的手机上面也是有着各种不同的版本,整理收集之后所有的版本都是可以直接的下载免费的推荐给你。

相关资讯